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Lab 1: Configuring Linux Desktop Settings 
 
Objectives: Understand the structure of the Linux desktop(s), KDE and GNOME, and their menus 

and the options for personalizing the desktop environment.  Learn some basic window 
handling operations and how to use workspaces. 

 

Exercise 1: Starting with the GNOME Basics 
 

  Log in as your workstation’s user, selecting a GNOME session from the “Sessions >” menu.  
Your home directory is on the lab’s NFS server.  Select “Yes” when asked to make GNOME 
your default session type.  You should see the “default” desktop. 
 

  Select “Applications > System Tools > Terminal” (the application menu has the RedHat icon) 
to open a terminal session.  Why this is not one of the default launchers is a mystery.  It is, 
however already on the right-click menu for the workspace background.  Point to the 
background, right-click, and select “New Window” to open another terminal session. 
 

  Let’s take a quick look at your login rc file, ~/.bashrc, just to make sure that things are set up to 
a very basic level.  Edit the .bashrc file by executing “vim ~/.bashrc”.  Note that vi and vim (vi 
improved) are one and the same.  They both will try to use color, so changing the background of 
your terminal sessions is a precarious thing to do.  Add the lines “alias ll=‘ls –al’”,  
“alias is=’ps –ef | grep’”, “alias ‘bdf=df’”, and “alias lanscan=’ifconfig’”.  Some of these are 
for the HP-UX administrators in the audience…  Note that the file sources /etc/bashrc if it 
exists, along with files in the /etc/profile.d directory if they end in the “.sh” suffix.  Save the file 
after making the modifications.  The default files in your home directory come from the /etc/skel 
directory (skeleton user configuration) and are placed there when your home directory is created 
by adduser. 
 

  If you examine the /etc/bashrc file, you will see that it does a bunch of mundane things like 
figuring out if your terminal session is interactive, etc.  One thing that is interesting is that the 
file will execute “shopt checkwinsize”, which is a bash built-in command that sets the shell 
option “checkwinsize”.  This option will automatically readjust the LINES and COLUMNS 
environment variables when the window is resized.  Thank you, Linux. 
 



  The default “panel” at the bottom of your workspace is sort of a home base for launching 
applications.  Let’s add a “launcher” to the panel that will start a terminal window.  Right-click 
the panel and select “Add to Panel > Launcher frm Menu > System Tools > Terminal”.  That 
will place a launcher, identical to the one in the menu, on the panel.   
 

  If you don’t like where it was placed, right-click on the terminal icon and select “Move”.  Your 
mouse pointer will change to indicate that you are moving the launcher.  You can now drag it to 
wherever you want it.  Note that the other inhabitants of the panel move out of the way.  When 
you get the terminal launcher where you want it, left-click. 
 

Exercise 2: Setting Some GNOME Preferences 
 

  There are a lot of preferences that you can set for your desktop.  We will not be able to cover all 
of them in these labs, there are just too many.  We will skim over some of the more important 
ones.  
 

  Select “Applications > Preferences > Control Center” to open the preferences browser.  
Double-click the “Windows” icon in the preferences window.  Choose your window focus 
preference.  I tend to use “Select windows when the mouse moves over them”, but that drives 
some people crazy.  To keep from driving myself crazy, I select “Raise selected windows after 
an interval” and a value of 1.0 seconds for the interval.  That way as you are pointing around, 
the windows will not raise until you have stopped in one for a second. 
 

  Note the “Double-click the titlebar to perform this action” is set to “Roll up”.  We’ll use this in 
a minute, so don’t change it.  Click “Close” to save the changes. 
 

  Now point to the “Preferences” title bar and double-click it.  What happened?  This is “rolling 
up” your window.  Double-click the title bar again to unroll the window.  There are lots of 
options that control window placement, and window relationships.  Explore a little. 
 

  Now double-click on the “Mouse” icon in the preferences window.  You can set the pointer size, 
the mouse speed, and the other options to your liking.  Click “Close” to save the changes. 
 

  Double-click the “Background” icon in the preferences window.  If you click on the “Select 
Picture” box, you will see a file widget that will present some optional backgrounds.  Also look 
in the /usr/share/backgrounds/tiles/Propaganda/Vol* directories, there are some cool images 
there.  I like the Vol2/15a.jpg file, personally.  You might need to change the “Picture Options” 
depending on whether you select a tile or a full image.  Click “Close” once you make your 
background selection. 
 

  Back in the preferences window, double-click the “More Options” icon, then double-click the 
“Sessions” icon.  I usually uncheck the “Prompt on logout” check-box and check the 
“Automatically save changes to session” box.  Make sure you check this box for our lab. 
 



  Examine the “Current Session” information by clicking on that tab.  The “Order” column 
determines which applications are started first when you log in.  The lower values start first.  
This is a way that you can keep away from the Microsoft Windows “launch-everything-at-once-
and-thrash” problem at login time. 
 

  We’re going to start the gkrellm tool.  Type “gkrellm &” in a terminal window.  Click “Okay” 
to acknowledge the configuration information, but don’t change anything just yet.  Click 
“Applications > Logout” to leave your session. 
 

  Notice the error message from the GNOME session manager.  The gkrellm tool did not answer 
the “save yourself” message from the session manager.  Tools may be integrated into the 
environment, or not.  This tool is not.  Click “Close” to log off.  It would be nice to have a 
timeout on the message(s).  Oh, well, get out the source code … 
 

  Log back in, making sure you again select a GNOME session.  Notice that gkrellm was restarted 
in spite of the message we got at logout.  A bug?  No, the session manager restarted gkrellm 
because it was running when we logged out.  It made the assumption that the tool was not smart 
enough to save the data about its location.  Not quite true. 
 

  Right-click on the top of the gkrellm window and select “Configuration”.  Select the 
“Remember screen location …” check-box, and set the “GKrellM width” to 100 (pixels) or a 
size of your choosing.   
 

  Next, click on the “Built-ins” arrow in the options to see a list of the available (by default) 
monitors.  Most of these read information from the /proc file system.  Explore the settings in 
gkrellm, making any desired changes, the click “Okay”. 
 

Exercise 3: Using GNOME Workspaces and the Pager 
 

  Notice the “pager on the panel, it contains the same title bar information as the windows on your 
current desktop.  Right-click on the box in the pager containing the “gkrellm” text and select 
“Put on All Workspaces”.   
 

  Examine the “switcher” right next to the pager on the panel.  The switcher has four quadrants, by 
default, that represent the four workspaces available to you.  Notice that there is now a small 
window represented for gkrellm in each of the four quadrants. 
 

  Right-click the switcher and select “Properties”.  Select the “Show only the current workspace” 
check-box, and notice that the switcher shows a larger representation of the open windows in the 
current workspace.  If you don’t have a terminal window open, open one or two. 
 

  Pick one of the window representations in the switcher, and click on it.  Note the window 
behavior.  Clicking on one of the quadrants that is not the current workspace will enable that 
workspace.  Switch to another workspace and notice that gkrellm is displayed there.  Go back 



and unselect the “Show only the current workspace” option and close the dialog box. 
 

  Select one of the open terminal windows and right-click on its title bar.  Select the “Move to 
workspace 3” option.  Make sure you have a terminal window open in the current workspace.  
Type “ls –al” in the windows, but do not type <Enter>.  Highlight the text of the command, and 
right-click on it.  Select “Copy” from the menu. 
 

  Move to the workspace containing the window you just moved, using the switcher.  Point in the 
terminal window, right-click, and select “Paste”.  Note this is different from the “normal” X-
windows behavior.  Hit <Enter> or <Ctrl-C> to get a new prompt.  Then middle click in the 
window.    Notice the “normal” X-windows behavior with the clipboard text. 
 

Exercise 4: Let’s Try KDE 
 

  Log out of your GNOME session and log in again selecting a KDE session from the login 
“Session >” menu. 
 

  You will immediately notice a similar look and feel (this is the Bluecurve theme provided by 
Red Hat to make the two desktops remotely familiar).  There the similarity ends for the most 
part. 
 

  Click “Close” to get rid of “Kandalf’s Useful Tips” if it appears.  You might leave the “Show 
tips on startup” checked if you want to learn obscure things about KDE each time you log in. 
 

  Right-click on the desktop and select “Configure Desktop”.  Click on the “Behavior” icon and 
click the “Enable desktop menu” option, then click “Apply”.  One difference already: you have 
the option to apply changes without exiting the dialog box. 
 

  Click “Display devices on desktop” the “Apply”.  Now click on the “Background” icon and 
select the “Browse” button.  Select the /usr/share/wallpapers/water01.jpg file and “Mode: 
Tiled” then click “Apply”. 
 

  Click on the “Screen Saver” icon and check the “Require password to stop screen saver” check-
box then click “Apply”.  Browse the available screen savers and pick your favorite, or just leave 
the setting at the default, “Random”. 
 

  Open two terminal windows using the “Application > System Tools > Terminal” menu item.  
Now right-click on the desktop and select 
“Windows > Unclutter Windows” from the desktop menu.  What happened to the terminal 
windows?  Now select the “Windows > Cascade Windows” menu item.  What happened? 
 

  Click “Okay” to close the “Configure Desktop” window.  Right-click on the panel and select 
“Configure Panel” from the menu.  Click on “Layout” and click the “Hiding” tab.  Check the 
“Hide automatically” option box.  Explore the options, then click “Okay” to close it. 
 



  Start a new terminal window, or use an existing one to type “gkrellm &”.  Notice that gkrellm 
starts at the same location as under the GNOME desktop.  This is because the gkrellm program 
saves its state information in the .gkrellm directory in your home and is independent of whatever 
desktop you are running.  The two desktops save their state in .kde* and .gnome* files and 
directories in your home directory. 
 

  Right-click on the gkrellm box in the pager (called the “task applet” in KDE).  Select “To 
Workspace > All Workspaces” to make the window visible in all workspaces.  Check the 
switcher (called the pager in KDE) to see that the window is visible in all workspaces.  
 

  Right-click on the desktop again and select “Configure Desktop.  Click the “General” tab, and 
enable “Desktop menu bar” by selecting the radio button.  Many of the desktop functions are 
now available at the top of your desktop window.  You can disable this menu by selecting 
“Desktop > Disable Desktop Menu” from the desktop menu. 
 

  Right-click on the desktop and select “Run Command”.  Type “konsole” into the input line and 
click “Run” or type <Enter> to open a new terminal window.  Right-click the desktop and select 
“Run Command” again.  Click on the down-arrow next to the input box and notice “konsole” is 
there.  Select it and click “Run”.  Pretty handy. 
 

Exercise 5: KDE Control Center Options 
 

  Okay, we have seen the “Configure Desktop” option window.  That is just scratching the 
surface, however with KDE.  Select “Applications > Control Center” to open the whole world of 
KDE konfiguration (notice that everything starts with a “k” in KDE?) 
 

  Open the “KDE Components > Session Manager” option and set your session prompting and 
behavior.  Then select “Desktop > Window Behavior > Advanced” and click the “Active 
Desktop Borders” option.  Click “Apply”.  Now grab the title bar of the “Control Center” 
window by pointing to it and holding down the left mouse button.  Drag the window to the right, 
off the screen.  Watch the switcher, er, the pager when you do this.  Notice that you are dragging 
the window into/onto the next workspace.  Try dragging up/down, right/left to see what happens.  
This is just a behavioral option that can be very useful (once you get used to it).  The edge-
flipping sensitivity, of course, is configurable. 
 

  Right-click the panel and select “Add > Applicaton Button > System Tools > Terminal”.  Right-
click on the launcher, er, “application button” and select “Move”.  Place it on the panel where 
you want it.  At least some things are similar between KDE and GNOME …  How many ways 
did you count to get a terminal window? 
 

  Now try double-clicking the title bar of a window.  Notice that it rolls up like in GNOME, but of 
course it is called “shading” in KDE.  Move your mouse pointer over the title bar and observe 
what happens.  Move the mouse pointer away.  Double-click on the title bar again and observe 
the change in behavior.  This is called “shade hovering” and is configurable, of course. 
 



Exercise 6: Using the KDE Klipper Tool 
 

  In the lower right part of the panel is an icon that resembles a clip-board.  This is the icon for the 
KDE klipper tool.  Right-click on the icon and make sure the “Actions Enabled” option has a 
check mark beside it.  You can also toggle enabling/disabling the klipper actions by typing 
<Alt-Ctrl-X>.  Right-click on the icon to open the “Configure Klipper” (Hey, why isn’t that 
“Konfigure Klipper?”   Check the “Popup menu at mouse-cursor position” option. 
 

  While we have the “Configure Klipper” window open, click on the “Actions” tab.  Note the 
regular expression that reads “^https?://.”, and click on the “+” next to it to open the sub-items.  
Take a look at the actions that are defined for the regular expression.  What this is for will 
become clear when we use the tool.  Click on the “OK” button to close the window.   
 

  Now go to a terminal window and type “http://www.hp.com” at the command line.  Left-click 
and drag the mouse cursor to highlight the text.  Notice the menu that appears.  Select the “Open 
with Mozilla” option.  This will start mozilla with the highlighted URL. 
 

  Any general action may be tied to a regular expression match on the clipboard with the klipper 
tool.  Take a look at some of the other actions available and try them out. 
 

Exercise 7: File Browsers – Konquereor and Nautilus 
 

  Since we are in KDE at the moment, we will take a look at the KDE file browser first.  Click on 
the “Home” icon on your desktop to open konqueror, the KDE browser.  I say browser, because 
konqueror is a web-browser and file browser all rolled into one.  Note the current URL in the 
status window: file:/<your_home_directory>.  If you don’t have a “Home” icon (it is a 
configuration setting), double click the “Start Here” icon.  Along the left side of the window that 
opens is a menu of locations, one of them is your home directory.  Double click on the “Home 
Folder” icon to open the directory in the browser.  If all else fails, open the konqueror browser 
manually and enter “file:/<your_home_directory>” in the URL input. 
 

  Click on the red folder icon in the far left window panel to open a view of the root directory.  
You might have to hunt for it.  Try clicking on the boot and etc directories in the tree view of the 
file system.  Note the icons being displayed for the various file types.  Some of the icons will 
display the file contents after a short delay. 
 

  Click on the yellow star in the far left window pane.  Note that it opens the “Services” view.  
Click on “Devices” to see a list of the mount points.  Click on “Harddisk (<disk>) mounted at 
/boot” to see a view of the /boot directory.  Note that the CD-ROM and floppy devices are 
included in the list. 
 

  Placing a CD in the drive will cause the device to be mounted.  An icon for the CD will appear 
on the desktop, and the status of the CD-ROM drive in konqueror’s “Devices” list will change 



to “CD-ROM (cdrom) mounted at /mnt/cdrom”.  Try this if you have a data CD-ROM.   
 

  A music CD will behave slightly differently.  An item named “Audio Browser” will appear in 
the “Devices” list, in place of the “CD-ROM (cdrom) …” description.  Under the “Audio 
Browser” will be “By Name”, “By Track”, “dev”, “Information”, “Ogg Vorbis”, and 
“<CD_name_from_Internet_database>”.  You can play the CD-ROM with the built-in KDE 
player, kaboodle. 
 

  You can also use konqueror to browse the web.  Enter “www.hp.com” in the “Location:” text 
box and type <Enter>.  Notice that the web page is brought up in the right-hand display panel.  
This type of behavior is available in both desktop browsers: using URLs to access information.  
Both browsers have special URL conventions to allow display of local files, FTP sites, web-
pages, CD-ROMs, and many more items. 
 

  Browse around and explore using konqueror. 
 

  For now, we are going to explore the GNOME file browser, nautilus.  Log out of KDE and back 
into GNOME.  You should know how to do this by now. 
 

  Double-click the “Start Here” icon on your desktop.  This will open nautilus  with a default 
“Location:” value of “start-here:///”.  Double-click the “Home” icon on your desktop.  This will 
open nautilus with a “Location:” value of “/<your_home_directory>”.  Note the different 
desktop behavior between KDE and GNOME (single versus double-clicking).  
 

  Type “/boot” into the “Location:” box.  Notice the icons and attached “emblems” for some files.  
The contents of some files is displayed, just like in konqueror.  To see what the emblems mean, 
you can click the “Information” down-arrow and select “Emblems” from the menu.  This will 
display a list of emblems and their meanings and change the menu name to “Emblems”.  Click 
the menu down-arrow again, and select “Information” to return to the normal display. 
 

  Now type “www.hp.com” into the “Location:” box and press <Enter>.  Notice that the html is 
displayed, a difference between nautilus and konqueror.  Click “Open with Mozilla” to open 
the page in a web browser. 
 

  If the lab has an external Internet connection, you can browse to the Red Hat software download 
site.  Enter "ftp://updates.redhat.com/9/en/os" into the “Location:” box.  You should see 
directories like i386, athlon, and i686.  Select one and double-click it.  .  Select one and double-
click it.  You should see the available rpm files in the directory. 
 

  Time to return to class now. 
 

 
 



Lab 2: Useful Linux Graphical Tools 

 
Objectives: Experience some of the useful tools that are provided with the Linux desktop 

environment. 

Exercise 1: Working With The GIMP 
 

  The Linux desktops provide the “GNU image manipulation program”, gimp, otherwise called 
“The GIMP”.  We will get a little flavor for what this program can do.  Anyone familiar with 
Adobe ® Photoshop ® will recognize some of the characteristics of “The GIMP”.   
 

  Select “Applications > Graphics > Gimp Image Editor”.  Continue clicking “Continue” on the 
options dialogs, until the program starts.  If you were setting up your own preferences, you might 
need to pay closer attention to the options.  We can use the defaults.  Click “Close” on the tips 
window to close it.  This leaves you with the main window, which contains the tool box.  Select 
“File > Open” from the main window’s menu. 
 

  Open the file /usr/share/backgrounds/images/space/apollo08_earthrise.jpg using the file 
selection dialog.  Right click on the image and select “View > Nav. Window” to open the 
navigation window.  Move the slider in the “Navigation Window” to “3:1” or “300%” to see a 
section of the enlarged image.  The navigation window’s white rectangle displays which portion 
of the image is viewable in the work area. 
 

  Right-click on the image.  Select “Filters > Light Effects > SuperNova” and click “OK” to apply 
the filter.  Next right-click on the image again and select “Filters > Artistic > Oilify”.  Again 
click “OK” to apply the filter to your image.  What a masterpiece, but don’t give you your day 
job just yet. 
 

  Save the image as another file, if you like, browse and play, or just exit “The GIMP”.  You could 
spend weeks learning all of the features of this program.  Continue on to the next exercise. 
 

Exercise 2: Using Ghostscript and Xpdf 
 

  Some of the Linux documentation is in postscript format.  This is fine if you have a handy 
postscript printer to use, but you can also display the information on your screen using the 
ghostview “gv” ghostscript interface.  To try out ghostscript, execute “gv /usr/share/doc/iprout-
2.4.7/ip-cref.ps” This will display the document on your screen.  Exit from the document after 
trying some of the viewing buttons. 

 
  Most of the printing on UNIX is done with postscript as the printer language.  This tool is very 

useful for viewing raw postscript output.  
 



  To try out xpdf, type “xpdf /usr/share/doc/Samba-2.2.7a/docs/Samba-HOWTO-Collection.pdf” 
exit from the document using the menu options.  Of course, there is a version of the Adobe ® 
Acrobat ® reader available for Linux.  You can download that for free or install it from one of 
the auxiliary Red Hat Linux CDs.  Continue to the next exercise. 

Exercise 3: Ximian Evolution Organizer 
 
  The Ximian® Evolution® organizer is listed under the menus as “Evolution Email”, but it is 

much more than just an e-mail tool.  It handles contacts, tasks, your calendar, and will connect to 
a Microsoft® Exchange® server with a special “connector” package that you can buy.  We will 
cruise through the tool here. 
 

  We will set evolution up to receive mail on your local host.   
Select “Applications > Internet > Evolution Email”.  Click “Next” in the “Welcome” screen if it 
appears.  Fill in values for your identity in the “Identity” screen, then click “Next”.  In the 
“Receiving Email” screen, set “Server Type” to “local delivery” and click “Next”.  Set the 
“Server Type” to “SMTP” and “Host” to “localhost” in the “Sending Email” screen, and then 
click “Next”.  Click “Next” in the “Account Management” screen.  Fill out the time-zone 
information and click “Next”.  Click “Finish” in the “Done” screen to finally enter the program.  
This setup may have been done for you prior to the class. 
 

  You will find yourself in the “Summary” page.  Note that Boston, Massachusetts is where 
Ximian headquarters is located.  The icons in the left window pane will select the major 
functions that are available in evolution.  Click on the “Inbox” icon, and notice (of course) that 
it is empty. 
 

  Explore the “Calendar”, “Tasks”, and “Contacts” functions.  Now select “Tools > Settings” 
from the main menu bar.  Click on the “Summary Preferences” icon, which is toward the bottom 
of the list.  This is where you can set up your email, news feeds, weather, and schedule options.  
Explore the settings. Notice the “VFolders” option in the “Mail” tab. 
 

  One of the unique features of evolution is called a “Virtual Folder”.   
You can select “Search > Create Virtual Folder From Search” in the main tool bar.  The 
evolution documentation says that “a virtual folder looks like a folder, acts like a search, and is 
set up like a filter.”  This lets you click on a folder representation to see email that is filtered 
from all of your email folders according to your criteria.  We can’t try this, unfortunately, 
because you don’t have a lot of email in your folders.   
 

  You can work off-line with evolution by clicking on the connector icon in the lower left corner 
of the window.  When the connectors are apart, you are off-line.  Clicking on the icon again will 
connect you to the network servers that you use.  Exit evolution when you are finished browsing 
around. 
 

  Continue to the next exercise. 
 



Exercise 4: Miscellaneous Graphical Tools 
 

  Select “Applications > Internet > More Internet Applications > gFTP”.  This will open a 
graphical FTP application.  In the “Host:” box, type “updates.redhat.com” and click the 
connection icon in the upper left corner (resembles two system monitors).  You should see the 
directory listing show up in the left display pane (if there is a live Internet connection in the lab). 
 

  Examine the left display pane and notice that it is your home directory.  You can drag and drop 
files from one pane to the other, depending on the direction of the transfer.  When you are 
finished experimenting, exit gFTP. 
 

  From the “Applications > Internet” menu, select “ethereal”.  You will need to enter the root 
password to run this tool.  Notice that the desktops have a way to ask for the root password for 
applications that require it, even though you are not logged in as root. 
 

  Select “Capture > Start” from the main tool bar.  This will open a dialog box.  For “Display 
Options:” select “Update list of packets in real time”.  Set the “Stop capture” option to 100 
packets.  Enable network name resolution and then click “OK”.  This will start capturing packets.  
Normally, name resolution will slow down packet capture and display.  You can also optionally 
capture to a file or files and do the analysis later. 
 

  When the capture stops, scroll around looking at the packets that got captured.  See how easy it is 
for someone to snoop your passwords or other non-encrypted data? 
 

  Try running “Traceroute” from the “Applications > System Tools” menu to see how many hops 
to your favorite web site.  You will also need to enter the root password to run this tool.  Enter 
the fully-qualified name of the site you want to access.  Click “Pause” after several cycles.  
Examine the data, then click “Quit” to exit the tool. 
 

  Start and explore the mozilla, galeon, and konqueror browsers.  Each has its strengths and 
weaknesses.  I use mozilla (actually Firefox). 
 

  Last, but not least, check out the game offerings.  There are a couple of good ones on the menus.  
8^) 
 

  Time to go back to class now. 



Lab 3: Microsoft ® Windows ® Interoperability 
 
Objectives: Use some of the Linux tools available to interoperate with Microsoft Windows systems 

and data formats.  Gain experience with the OpenOffice tools, CrossOver Office, and 
VMware. 

 

Exercise 1:  OpenOffice, Koffice, and Other Tools 
 

  Log into a GNOME session as your workstation’s user.  Three large icons in the panel will 
launch the OpenOffice tools: Writer, Impress, and Calc.  Locate these launchers and the 
OpenOffice tools in the “Application” menu.  Launch the Writer application. 
 

  OpenOffice will ask you to import your address book information from one of several sources, 
with the default being Mozilla.  Click “Next” to import the address book.  Select “Personal 
Address Book” as the source, then click “Next”.  Click “Create” to create the address book, then 
click “OK” to confirm. 
 

  Now choose “View > Zoom > Page Width” from the main tool bar menu.  Type some text into 
the document.  A 5000-word essay on why Linux is a good idea will do.  Select “File > Save As” 
from the main tool bar.  Enter “mydoc” for the “File name:” and select “Microsoft Word 
97/2000/XP” for the “File type:” information.  Click “Save”, and then select “File > Exit” from 
the main tool bar.  Answer “OK” to the dialog box about losing formatting.  Notice all of the 
different formats that may be created, including the “Export in PDF” option. 
 

  Now start the Impress tool from the panel.  Create a presentation.  Have fun!  Select  
“File > Save As” in the main tool bar and then select “mypresentation” for “File name:” and 
“Microsoft Powerpoint 97/2000/XP” for “File type:”.  Click “Save”.  Select “File > Exit” and 
answer “OK” to the formatting dialog box. 
 

  Follow the same procedure for Calc.  Start the tool, then create a spreadsheet by entering three 
integer values in cells A1, B1, and C1.  Click on cell A3 and type “=’.  Notice that the default 
function, SUM() appears in a display box.  Hit <Enter> to select SUM for your formula.  Note 
that the cursor is positioned between the parentheses.  Point to cell A1, left click and drag the 
mouse pointer to highlight cells A1 through C1.  Note that the range should have been entered 
into your formula, which should read “=SUM(A1:C1)”.  Hit <Enter> and save the file as 
“mycalc” following the directions for the previous three tools and selecting “Microsoft Excel 
97/2000/XP” for the “File type:”. 
 

  Log out of GNOME and log into KDE.  Select the individual KOffice tools, KSpread, 
KPresenter, and KWord to open the files you created under GNOME.  You might find some 
format incompatibilities …  The trick is to pick a common format like PDF that everyone reads 
and writes.  Note that both sets of tools are available in both environments under the  
“Applications > Office > More Office Applications” menu.  Select “Applications > Office > 



More Office Applications > KOffice Workspace” to see an integrated workspace with all of the 
Koffice tools available.  You will need all of your documents in the next exercise. 
 
 

Exercise 2: Running MS Office with CrossOver Office 
 
  Up to this point, we have been using native Linux KDE and OpenOffice tools that 

read and write Microsoft Office format files.  CrossOver Office from CodeWeavers is 
installed on your system.  Select the “Applications > CrossOver > Office Setup” item 
from the menu.  This will open a window that shows what software is installed under 
CrossOver Office.  The tools include: Microsoft Internet Explorer, Word, 
Outlook, Powerpoint, Excel, Visio, and Adobe Photoshop 7.   
 

  Notice that you can set up MIME associations for the Microsoft file types in the 
Linux MIME database.  The menu items for these programs have been created under 
“Applications > Windows Programs > Programs”.  Do not change anything in the 
“Office Setup” menu!  Click “Cancel” to exit the window. 
 

  Try running these tools with the data files that you created with the Linux desktop 
office tools.  Two notes: 1) the CrossOver office tools start up with their origin at the 
upper left corner of your desktop – you may need to disable the desktop menu until 
you have started them once, and 2) the MS Office tools all start out maximized (a 
hold-over from the Windows behavior) – you should change the mode so that they do 
not take up the whole screen.  These steps will make things easier for you to get 
started. 
 

  For Outlook, set up your account by clicking “Next” to the setup wizard, then select 
“no E-mail”, followed by “Next” to get started. 
 

  Try running Adobe Photoshop 7 with some of the files from 
/usr/share/backgrounds as data. 
 

  In all of the tools, observe that they behave (mostly) as you would expect, because 
they are the original code.  The libraries comprising the application are loaded and 
executed directly by the system’s processor.  WINE stands for “WINE Is Not an 
Emulator” for that reason.  The performance is quite good on a fast-enough processor. 
 

  Exit any of the applications that might be running, and continue to the next exercise. 
 



Exercise 3:  Running the VMware Virtual Machine 
 
  Your system has the VMware software installed, and a pre-configured virtual 

machine with Windows XP installed in /vmdata. 
 

  To run the VMware software, execute  
“/usr/bin/vmware /vmdata/WinXPPro/winXPPro.vmx”.  If you want to add a 
launcher to the panel or the desktop, the icon for VMware is located in 
/usr/share/icons/slick/32x32/apps/vmware.png. 
 

  Some tips about VMware:  1) to release your cursor from the virtual machine 
window, type <Ctrl-Alt>, 2) you can put the virtual machine into full-screen mode 
(which is faster than a separate window) by typing <Ctrl-Alt-F8> and to return to 
“normal” display, type <Ctrl-Alt-F7> (this is the default virtual screen used by the X-
windows server). 
 

  Your instructor will give you things to try based on how much setup he was able to 
complete successfully.  The virtual machine should be configured to have a “bridged” 
network connection and a “host-only” network connection.  The bridged network 
connection makes the virtual machine look like another PC on the network, it gets a 
DHCP address, but is “sharing” the host’s network interface.  The host-only network 
connects to a system-local network to allow sharing the host’s file system with the 
virtual machine via SMB.  This all takes some work to set up, and the lab 
environment may not allow it … 
 

  The virtual machine has a full version of Windows XP Professional, Microsoft Office 
XP, and numerous other tools installed.  It is just like a real PC.  On a dual-CPU 
machine, where one CPU can run Linux and the other can basically run the virtual 
machine (the VM actually just looks like a Linux process), this is a screaming setup 
for interoperability with Windows software. 

 

Lab 4: Knoppix 
 
Objectives: Introduce a disk-free desktop environment, Knoppix.  Knoppix boots from a CD-ROM or 

DVD, and provides a full Linux desktop environment. 
 

  Your instructor will give you some suggestions for using Knoppix in the lab.  Our exposure 
will depend on how much time is left. 
 

  That is the labs for today.  I hope you learned a lot.  Just being exposed to this 
information will make you better able to configure solutions for yourself or your 
users.  Feel free to use remaining time to experiment.  Thank you! 

 


